My Memory Dump

Aller au contenu | Aller au menu | Aller à la recherche

Système d'exploitation

Fil des billets - Fil des commentaires

vendredi 4 septembre 2015

Windows 10 - Un petit instant

J'ai installé Windows 10 FR Pro RTM dans une VM Hyperv à l'aide de l'image iso. Après le premier redémarrage, l'installation est restée bloquée sur "Un petit instant"

Un petit instant

J'ai attendu plusieurs heures, pareil.

Après recherche, la solution consiste à débrancher toute connexion réseau / Wifi / Bluetooth et à redémarrer, même pendant la présence du message.

J'ai refait l'installation, durée : 10 min pour atteindre l'écran de connexion (ah ! j'aime mieux ça). C'est magique Windows 10 ...

jeudi 4 juin 2015

Lync 2013 web conférences, ajout automatique ?SL=1

Pour utiliser Lync 2013 en mode Web Conférence, il suffit d'envoyer l'URL de la réunion à ses interlocuteurs.

Si ceux-ci utilisent Internet Explorer comme navigateur par défaut et qu'il ont Office 2013 installé sur leur poste, le navigateur s'ouvre et démarre le client Lync 2013 (Skype for business désormais). Ce n'est pas ce que l'on veux. Il s'agit d'une web conférence, on souhaite n'utiliser que le navigateur. Il faut que le processus soit simple et fluide.

La solution fourni par Microsoft consiste à ajouter le paramètre '?sl=1' à la fin de l'URL d'accès à la réunion.

Comment faire cette modification de manière permanente et définitive ?

La solution consiste à utiliser le module de ré-écriture d'URL de IIS, celui-ci est déjà présent sur le serveur Lync.

- Se connecter au serveur Lync et lancer la console de gestion de IIS.
- Se placer sur le site "Lync Server External Web Site" et double cliquer sur l'icône "URL Rewrite"
- Créer une nouvelle règle entrante (inbound rule) avec les paramètres suivants :

Lync 2013 rewrite rule

- Placer la règle en deuxième position dans la liste, juste en dessous de "Règle de redirection HTTPS".

Remarque : Je n'est créé cette règle que dans le site web externe. En interne, nos utilisateurs ne font pas de web conférence, ils utilisent le client Lync.

dimanche 25 janvier 2015

WDS : erreur 0xC0000001

Symtôme : Au démarrage d'une image de boot WDS (de capture ou de déploiement) l'erreur suivante apparait :

Status: 0xc0000001
Info: A required device isn't connected or can't be accessed.

Cause générale : Problème réseau avec le protocole TFTP qui télécharge l'image de boot du serveur WDS vers l'espace RAMDisk du poste client.

Cause particulière : Pour préparer mes images WDS, j'utilise une machine virtuelle hyper-v, cela permet de prendre un cliché avant d’effectuer le sysprep pour revenir en arrière en cas de problème. Le serveur WDS (2012 R2) est également virtualisé.
Après le sysprep, Je lance la capture en utilisant l'image de capture WDS et le boot PXE dans la vm. L'erreur apparait pendant le téléchargement de l'image de capture.
Ce problème n'est pas systématique, parfois il suffit de recommencer pour que ça fonctionne.
Le problème ne se produit pas avec les machines physiques.

Après recherche, il se trouve que le protocole TFTP ne supporte pas bien le Teaming de carte réseau, Teaming de carte qui est configuré au niveau du serveur Hyper-v.
https://social.technet.microsoft.com/Forums/en-US/1cffa232-1b0f-48c3-bbfd-b452858ca973/problems-with-pxe-boot-on-hyperv-guests?forum=configmanagerosd

Solution 1 : Connecter la machine virtuelle à une carte réseau indépendante du Team du serveur hyper-v.

Solution 2 : Générer du trafic réseau entre le serveur WDS et un autre serveur, par exemple en exportant une image WDS depuis la console. Il suffit que ce trafic réseau soit important pendant la phase de téléchargement de l'image de boot. Ensuite, dés qu'elle démarre vous pouvez arrêter l'export en cliquant sur annuler.

Solution 3 : Booter la vm avec le disque d'installation de Windows, puis, arrivé au premier écran en mode graphique, taper MAJ+F10 pour lancer une console. Utiliser GImageX pour effectuer la capture. Cela suppose au préalable d'avoir placé cet outil sur la partition prévue pour le stockage de l'image. Une fois la capture finie, redémarrer la VM, la laisser la se respécialiser (suite au sysprep) puis télécharger l'image vers le serveur WDS.

samedi 24 janvier 2015

Click droit : Menu contextuel inactif

Symptôme : Sous Windows 8.1, le menu clic-droit "Exécuter en tant qu'administrateur" ne fonctionne plus pour lancer "cmd" (entre autre), c'est-à-dire que rien ne se passe après le clic. Autre cas, le raccourci clavier Win + X (clic-droit sur le bouton démarrer) affiche le menu attendu mais une partie des sous menus est inerte, rien ne se passe lorsqu'on clique dessus. Le problème est apparu subitement.

Cause : Un programme a ajouté une extension invalide au Shell.

Solution : Pour identifier la ou les extensions responsables de ce dysfonctionnement, utiliser ShellExtView. Ce programme affiche la liste des extensions configurées, Il suffit de trier par date et de désactiver, une par une, les extensions modifiées récemment. Dans mon cas, le problème venait de "Compare it", outil de comparaison de fichier qui ajoute une extension au clic-droit sur les fichiers dans l'explorateur. Après désactivation, tout refonctionne comme avant.